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Product Warranty Statement

LINK ENGINE MANAGEMENT LTD — LIMITED LIFETIME WARRANTY

All Engine Control Units (ECUs) manufactured or distributed by Link Engine Management Ltd are
subject to the following LIMITED LIFETIME WARRANTIES, and no others.

Link Engine Management Ltd warrants only to the original purchaser of the ECU, for the lifetime of
the ECU, (subject to the limitations set out below), that the ECU shall be free from defects of
materials and workmanship in the manufacturing process. This warranty ceases to apply and does
not apply to ECUs that have not been manufactured or distributed by Link Engine Management Ltd
for a period of greater than one year.

An ECU claimed to be defective must be returned to the place of purchase. Link Engine Management
Ltd, at its sole option, may replace the defective ECU with a comparable new ECU or repair the
defective ECU.

This limited lifetime warranty is not transferable and does not apply to any ECU not properly installed
or properly used by the purchaser or end user, or to any ECU damaged or impaired by external
forces. The above warranties are the full extent of the warranties available on the ECU. Link Engine
Management Ltd has no liability to the original purchaser or any other person for any loss, injury or
damage to persons or property resulting from the use of the ECU or any failure of or defect in the
ECU whether by general, special, direct, indirect, incidental, consequential, exemplary, punitive, or
any other damages of any kind or nature whatsoever. Link Engine Management Ltd specifically
disclaims and disavows all other warranties, express or implied, including, without limitation, all
warranties of fitness for a particular purpose, warranties of description, warranties of merchantability,
trade usage or warranties of trade usage.

For off-road use only, not intended for highway vehicles. This ECU contains a user-configurable
software programme, which is updated by Link Engine Management Ltd from time to time. The user
must ensure the current correct version of this programme is downloaded from the website of Link
Engine Management Ltd and installed in the ECU prior to use. This limited lifetime warranty does not
apply where the ECU has been installed with the incorrect version of the software programme. The
user is solely responsible for the setup and testing of all user-configurable features.

Link Engine Management Ltd License Agreement

The software programme in this ECU is licensed not sold. Link Engine Management Ltd grants the
user a license for the programme only in the country where the programme was acquired. No other
rights are granted under this license and the programme may only be used on one machine at a
time. If the programme is transferred a copy of this license and all other documentation must be
transferred at the same time. The license may be terminated by the user at any time. Link Engine
Management Ltd may terminate the licence if the user fails to comply with the terms and conditions
of this license. In either event the copy of the programme must be destroyed.
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G4X Plug-In ECU Installation Manual
Introduction

Thank you for purchasing your Link Plug-In Engine Control Unit (ECU), an advanced, fully programmable

microprocessor controlled Engine Management System.

G4X software employs high resolution fuel and ignition tables with configurable load and RPM centres. When

coupled with up to six dimensional fuel and ignition mapping, barometric pressure compensation and intake

air temperature correction this gives an unprecedented level of tuning accuracy. All Link G4X ECUs are in-field
upgradeable, there is no need to return the unit for software updates.

All Link G4X Plug-In Engine Management Systems are designed with flexibility and ease of installation in

mind. Link Plug-In systems are designed to replace the circuit board inside the factory ECU enclosure. This

provides an invisible install that requires minimal modification to vehicle wiring and ECU mounting.

Installing and tuning any after market engine management system is not to be taken lightly. G4X ECUs give

the tuner the control & flexibility that only top after-market engine management systems in the world can

provide. While every effort has been made to keep G4X ECUs as user friendly as possible, it should be
recognised that added features bring added complexity.

The complete setup of your ECU can be divided into two important tasks:

1. This manual covers the installation of your G4X ECU. While it is not strictly essential that this work is
performed by an automotive electrician, the knowledge and tools available to these professionals makes it
highly recommended. Regardless of who does the installation, it is of utmost importance that instructions
provided in this manual are followed exactly throughout the installation.

2. Once the G4XECU has been installed it will need to be tuned using a laptop computer with PCLink
software. Information on the configuration and tuning of the G4X ECU is detailed in the help section of
PCLink. G4X ECUs are shipped pre-loaded with a base configuration that should be close enough to get
most engines running after a few application specific adjustments have been made. While hearing the
engine running on the new ECU for the first time is always a satisfying feeling, it is important to realise
that the job is not complete. The amount of tuning performed and the experience of the tuner are the two
most important factors in determining how happy you will be with your engine management system.

Safety Notice

Your Link Plug-In ECU is designed to enhance the performance of your vehicle. Howewer in all cases, your
vehicle must be operated in a safe manner. Do not tune your vehicle while operating it on public roads.
WARNING!
Failure to follow all installation and operating instructions may result in damage to
the Link ECU, personal injury, or harm to property.

Disclaimer

All care has been taken to ensure the pin outs and interconnections of the ECU to the vehicles wiring harness
are correct. However due to variations between vehicle models it is the installers responsibility to check wiring
connections BEFORE installing the ECU. Link will not be held responsible for any damage caused by the
incorrect installation of this product.

Support Options

Should any issues arise during installation, the following options exist for technical support:

1. PCLink help, press F1 while running PCLink

2. Contact your nearest Link dealer. A Link dealer list is available on our website.

3. Link website: www.linkecu.com with Online Discussion Forum.

4. Technical Support Email: tech@linkecu.com

The majority of questions received by the technical support team are clearly answered in the manuals. Please
consult the manuals to make sure that your question has not already been answered.

Pre-Installation

Before installing the Link G4X ECU into the vehicle some pre-installation checks must be performed.

© 2020 Link Engine Management Ltd
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1.2.1 Compatibility Check

It is essential that a compatibility check is performed before installing the ECU into the vehicle. Failure to do

so may woid the warranty. There are some cases where the same ECU connector is used on very similar
vehicle models but with a completely different pinout.

1.2.1.1 MR2Link V1

WARNING: Some models of ST185, particularly the ST185RC (Carlos Sainz Edition) do not use the ST185
ECU pinout. Instead the MR2Link V2-3 ECU must be used on this model. Please refer to the vehicles actual

wiring and the pinout diagram in this manual and the MR2Link V2-3 manual to determine which ECU should
be used.

1.2.2 Injector Impedance

Injector impedance is important and needs consideration before installing the ECU.
1.22.1 MR2Link V1

The G4X MR2Link V1 Plug-In ECU is NOT designed to be used directly with low impedance injectors.
All models this ECU is designed for are fitted with low impedance injectors from factory. Current through low
impedance injectors is reduced by the use of factory fitted injector ballast resisters. This means that the ECU

is plug-in compatible with factory fitted injector combinations on all models. DO NOT remove the factory fitted
ballast resisters.

1.2.3 Multi-coil Ignition Upgrade

Factory distributed ignition systems can be upgraded to a multi-coil setup.
In some cases factory waste spark ignition systems can be upgraded to direct spark.
1.2.3.1 MR2Link V1

The G4X MR2Link V1 Plug-in ECU has an ignition expansion connector to support an upgrade to a Direct or

Wasted Spark ignition system. The Expansion Connector section of this manual provides pin information
useful for performing this upgrade.

1.3 Installation

This guide provides information on correctly and safely installing your new Link G4X Plug-In ECU.

1.3.1 ECU Handling Procedures

WARNING!!!

The following installation process will require handling of both the Link ECU and
factory ECU. Both of these are highly sensitive to electrostatic discharge and are
easily damaged. Follow the anti-static precautions given in this manual carefully

to awoid damaging electronic components. Warranty claims for ECUs damaged by
electrostatic discharge will NOT be accepted.

© 2020 Link Engine Management Ltd
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ANTI-STATIC HANDLING GUIDELINES
Your body builds up an electrical charge as you mowe around. This charge can reach very high
wltages. Whenever given the opportunity this energy will attempt to discharge (usually through

your finger tips!). This can be fatal to most electronic components. Most people have
experienced an electrostatic discharge when they step out of their car or touch a metal bench
top.
1. The following guidelines describe precautions that can be taken to reduce the possibility of
damaging your ECU:
2. Work only on a conductive surface. A clean steel bench is suitable.
3. Always wear a wrist strap that is electrically connected to the conductive working surface.
4. Touch the working surface regularly.
5. Do NOT touch components on the circuit board.
6. Where possible, only handle the ECU by its plastic header.
7. Do NOT carry the ECU around without anti-static packaging.
8. Do NOT touch the bare terminals in the ECU header.
Obsening the above procedures will minimise the chance of damaging the ECU. Note that
failure due to static damage often does not appear until well after it was caused.
1.3.2 Fitting the ECU
Information is provided to assist in fitting the ECU into the vehicle.
1.3.2.1 MR2Link V1, MR2Link V2-3 and SupraLink

The following steps outline the installation procedure:

1.

>

® N

Removwe the factory ECU from the vehicle: Ensure the key is in the OFF position. The factory ECU is
located:

e Celica and JZX100 - in the center of the vehicle under the dash

o MR2 - in the boot attached to the firewall

e Supra - under the passenger foot panel

Unplug the wiring harness from the factory ECU. Remowe the bolts that retain the ECU mounting
structure and remowve the ECU from the vehicle. DO NOT touch the exposed pins in the factory ECU
connector.

Removwe the factory ECUs circuit board from its enclosure: Ensure you are following the given anti-static
guidelines and ARE WEARING A CONDUCTIVE WRIST STRAP connected to a conductive working
surface. Remowe the top cover by removing the side retaining screws. Remowe the circuit board by
removing the corner screws. Hold it only by the plastic header and place it aside.

Modify the case if required: It may be necessary to cut the center bar out of the enclosure using the
appropriate tool. This will be necessary if the center bar interferes with the ECU.

Connect the ECU USB tuning cable and the expansion loom to the Link Plug-In ECU if required.

Fit the Link Plug-In ECU: Place the Link ECU on the base plate and carefully fit the four corner screws.
Place the factory ECU in the packaging your Link ECU came in for its protection.

Refit the top cowver: It may be necessary to widen the slot around the main header to allow cables to exit.
Ensure that any modifications are de-burred to prevent cutting into cable insulation.

Reassemble the enclosure and fit the ECU back to the vehicle.
Connect the ECU to the factory wiring loom.

Do NOT attempt to start the vehicle. Proceed to read through the remaining sections of this manual first.

© 2020 Link Engine Management Ltd
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Note: The bolt that holds the Toyota Supra header plug in place will screw right through all the thread and
spin. This is normal.

1.4 Additional Sensors/Functions

G4X Plug-In ECUs offer various options for the installation of additional sensors and devices. As a minimum it
is recommended that all ECUs are installed with a Manifold Absolute Pressure (MAP) sensor and Intake Air
Temperature (IAT) sensor. These parts can be purchased if required from your nearest Link dealer.

141 MAP Sensor

It is important that the pressure source for a MAP sensor be taken from a stable pressure source after the
throttle body. It is common to 'T into the fuel pressure regulators pressure signal. Do NOT share this signal
with other devices such as boost gauges or blow off valves.

1.4.1.1 MR2Link V1

The G4XMR2Link V1 Plug-In ECU supports several options for fitting of a MAP sensor. Any one of the
following options can be used:

1. Factory MAP Sensor. The factory MAP sensor is wired to AnVolt3. This sensor is good for 125kPa (18psi)
of boost.

2. MAP Through Expansion Connector - The expansion connector provides power, ground, and analog
channels for the connection of a MAP sensor.

Make sure that the correct MAP sensor input has been selected in PCLink and a MAP calibration has been
performed before attempting to start the vehicle.

142 |AT Sensor

It is highly recommended that an IAT sensor be fitted in all applications to provide an input for correction of
fuel and ignition based on the engines air charge temperature.

An IAT sensor should be fitted in the intake system in a location that accurately represents intake
temperature. The most common location is just prior to the throttle body. Installing in the manifold is not
recommended due to heat soak issues. A fast response sensor must be used in all forced induction
applications.

1.4.21 MR2Link V1

From factory, models supported by the G4X MR2Link V1 Plug-In ECU may be fitted with a suitable IAT
sensor. The G4X MR2Link V1 Plug-In ECU supports several options for fitting of an IAT sensor. Any one of
the following options can be used:

1. IAT Through AFM Connector - The AFM has a factory fitted IAT sensor. Due to its location this sensor is
not suitable for tuning. A suitable IAT sensor can however be wired to the AFM wiring. The AFMs IAT
signal is wired to An Temp 2. Consult factory wiring information for AFM wiring information.

2. |AT Through Factory Header- The temperature sensor can be wired to pin 45 (connected to AnTemp3) on
the factory header plug. See the Pinouts section for further information.

3. IAT Through Expansion Connector - The expansion connector provides ground and input channels, spare
An Volt channels can be used as temperature inputs when a pullup resistor (to +5V) is added.

1.4.3 E-Throttle Output

It is becoming more common to convert cable throttle vehicles to Electronic Throttle control, this section
explains how (if it is possible) to do this for each plugin.

1.4.3.1 MR2Link V1

Aux 9 & 10 are not exposed on this plugin and so to use E-Throttle it is recommended to use Aux 1 & 2 (ISC
Close and ISC Open) with an external E-Throttle controller.

Three Analog inputs are available on the expansion connectors which can be used to add TPS (Sub) and the
APS inputs.

© 2020 Link Engine Management Ltd



10

Link ECU Online Manual

144 Expansion Connector

Expansion connectors are provided to allow easy connection of additional ECU inputs. An “expansion cable”

can be purchased from your Link dealer.

Important points when wiring to the expansion connector:

e Do not owverload the +5V Out pin. Although this is protected against ECU damage the +5V out signal also
provides power for other sensors.

¢ Do not connect the ground pin to chassis ground. This could cause ground loops and introduce
unnecessary interference. Use this pin only to ground external sensors that are isolated from chassis
ground.

The Expansion connectors available for each ECU can be found under the Pinouts Section.

1.5 PC Tuning

1.5.1

1.5.2

1.5.3

G4X ECUs require PC/laptop tuning using the PCLink Tuning Software application running on a Windows
based computer. PCLink may be downloaded from www.linkecu.com. Note that when new versions of PCLink
are released they are posted on the website and may be downloaded at no cost. Also note that G4X ECUs
must be used with the correct version of PCLink.
IMPORTANT!
The G4X ECU has on board USB.

BEFORE connecting the ECU to your laptop, the USB drivers must be installed.

Failure to install the drivers on your laptop first may result in windows assigning

incorrect drivers. These drivers will not work with the G4X ECU and are difficult to

uninstall. The correct USB drivers are installed as part of PCLink installation, as

described in the following section. Should internet download not be practical, a

copy of the drivers on CD can be obtained from your nearest Link dealer.

Installing USB Drivers

Before connecting the ECU to your laptop or PC, the ECU USB drivers must be installed. These drivers are
installed as part of PCLink installation as described in the following section. Should internet download not be
practical, a copy of the drivers on CD can be obtained from your nearest Link Dealer.

Installing PCLink Tuning Software

Due to the frequent updates PCLink is no longer shipped with each ECU. You will be required to download the

latest version of PCLink from: linkecu.com

Should access to an Internet connection be impractical, download the latest version of PCLink elsewhere to a

USB drive, and then install on your laptop.

Installing from the web

1. Go to the above website and navigate to the downloads and software updates section.

2. Download the latest version of PCLink. When prompted to run or sawe the file, select sawe. It is
recommended to sawe this file on the desktop.

3. Double click the saved file and follow on screen instructions.

4. When prompted to install USB drivers, select yes. This may take some time.

5. When installed, open PCLink by double clicking on the icon that has been placed on the desktop.

Communicating With Your ECU

After PCLink installation, you will be able to connect the G4X ECU to the laptop to perform set-up and tuning

work.

1. Connect the ECU to your laptop using a Link G4X ECU USB Cable. If not supplied with the ECU, these
can be purchased from a Link dealer. No other adapter or cabling is required. Connect the cable to the
connector labelled USB.

2. If this is the first time you have connected a G4X USB ECU to your laptop follow the driver installation
instructions that appear. When prompted if you want to install drivers select 'Continue Anyway".

3. Start PCLink by double clicking on the PCLink icon on the windows desktop.

4. Switch the key to the ON position. This will provide power to the ECU.

© 2020 Link Engine Management Ltd
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5. In PCLink, under the 'Options' menu, select 'Connection'. The connection options dialogue will open.
Select the correct COM Port number from the drop down list or select auto for automatic com port
detection.

6. PCLink offers both mouse and keyboard control. To establish a connection between the PC and ECU

press the F3 key. The same process can be used to disconnect. If a successful connection is

established, PCLink will download settings from the ECU, otherwise you will be warned that an error has
occurred.

Make sure the connection shows “ONLINE” in the top right corner of PCLink.

8. To permanently STORE any changes made to the ECU press F4. If this is not done before turning the
ECUs power off all changes made will be lost.

N

1.6 Pre-Start Configuration
Before starting the vehicle, important pre-start configurations need to be made.
1.6.1 Firmware Version

It is recommended to ensure that the Link G4X ECU is running the most up to date firmware. Firmware
version information can be obtained by connecting to the ECU with PCLink and selecting 'ECU Information'
under the Help menu.

The latest firmware can be downloaded from our website with PCLink.

It is recommended that this is performed by an experienced Link dealer as new features may need to be
properly configured.

The firmware can be updated by selecting 'Update Firmware' under the 'ECU Controls' menu in PCLink, follow
the on screen instructions to complete the firmware update process.

1.6.2 Base Configuration

All G4X Plug-In ECUs are shipped with base configuration settings. Note that these are provided to reduce
initial setup and tuning times. They are NOT recommended tuning values. PCLink includes base
configurations for various models. Download the appropriate base configuration into your ECU with PCLink by
connecting to the ECU (described in the Connecting To PCLink section of this manual), then selecting 'Open'
under the 'File' menu. Select the appropriate .pclx file and then select 'Open'. Downloading large configuration
files can take up to a few minutes. Be patient and acknowledge any messages PCLink shows.

1.6.3 MAP Sensor Calibration

At key on and engine not running the Manifold Absolute Pressure (MAP) Sensor should always match the
Barometric Absolute Pressure (BAP) Sensor. As well as providing altitude correction, the BAP sensor also
allows the MAP sensor to be calibrated prior to tuning.

Link G4X ECUs use an on-board barometric sensor that is calibrated prior to dispatch. This ensures that all
PCLink Tuning Software programs (pclx Files) give a consistent state of tune throughout the ECU range. This
allows a pclx file to be transferred between G4X based ECUs giving an equivalent state of tune providing all
factors affecting volumetric efficiency are equal.

Without the ability to calibrate all the available types of MAP Sensors to the BAP Sensor there would be
significant affects on the accuracy of the resulting tune, especially when tuning with Manifold Gauge Pressure
(MGP) as a load index.

To calibrate the MAP sensor:

1. Connect a laptop/notebook PC to the ECU and connect to the ECU using PCLink.

2. Under the Analog Channels menu, select the An Volt channel that has been wired to the MAP sensor.
Select the correct MAP Sensor Type.

Under the 'Options' menu, select 'MAP sensor calibration'.

Follow the on screen instructions.

Select the 'Analog Inputs' tab in the runtime values section of PCLink (lower part of the screen).

Compare the MAP and BAP values and ensure they have a similar reading (within 1 kPa).

Perform a 'Store' by pressing F4.

No oA

A more in depth explanation is provided in the PCLink help Manual under PCLink G4X Users Manual ->
Tuning Operating Procedures -> ECU Controls -> MAP Sensor Calibration.

© 2020 Link Engine Management Ltd



12 Link ECU Online Manual

1.6.4 TPS Calibration

The Throttle Position Sensor (TPS) is used by the ECU to calculate various engine management parameters
used by functions such as idle speed control,acceleration enrichment and motor sport features. It is important
that the ECU knows when the throttle is open and closed (or part way in between). The following procedure
calibrates the ECU to match the TPS and is for engines using a cable driven throttle:

1. Connect a laptop/notebook PC to the ECU and connect to the ECU using PCLink.

2. Under the Analog Channels menu, ensure that the correct An Volt channel is set to "TPS (Main)'. Refer to
the pin functions section of this manual for details.

Under the 'Options' menu, select 'TPS calibration'.

Follow the on screen instructions.

Select the 'Analog Inputs' tab in the runtime values section of PCLink (lower part of the screen).

Ensure the Throttle Position value reads 0% when the throttle is closed and 100% when fully open.
Perform a 'Store' by pressing F4.

Noohs®

For engine setups that use Electronic Throttle Control the Accelerator Position Sensor (APS) and Throttle
Position Sensor (TPS) need to be calibrated.

For Link Plug-in ECUs see PCLink Help > G4X ECU Tuning Functions > Electronic Throttle Control
1.6.5 IAT Sensor Selection

This section only applies when an Intake Air Temperature (IAT) sensor has been wired and fitted to the intake
system. It is important that the ECU is calibrated to match the sensor installed in the engine. This procedure
is as simple as selecting the correct sensor type as follows:

1. Connect a laptop/notebook PC to the ECU and connect to the ECU using PCLink.

Click on 'Analog Channel' in the configuration tree.

Select the An Temp channel the sensor has been wired to.

Ensure that channel (and only that channel) is set to 'Inlet Air Temperature'.

Select the correct Temp Sensor Type'.

Select the 'Analog Inputs' tab in the runtime values section of PCLink (lower part of the screen).

Ensure that IAT reads the correct temperature.

8. Perform a 'Store' by pressing F4.

1.6.6 Inputand Output Setup

As the Link G4X Plug-In ECUs are designed to run several models there are a few items that must be set-up
to make the ECU specific to your model.

The Pin Functions section of this manual gives a list of the functions of each channel based on the target
vehicle.

It is the tuners responsibility to make sure that the following channels are set-up correctly for the vehicle
model the ECU is fitted to:

All Auxiliary Output Channels

Use the Test On' or Test PWM' (at 10 Hz) functions to test the wiring of channels.

All Digital Inputs

Look at the Digital Inputs runtime values (lower section of the PCLink screen) to confirm each channels
operation.

All Analog Volt and Temperature Inputs

Look at the Analog Inputs runtime values (lower section of the PCLink screen) to confirm each channels
operation.

NookwdD

1.6.7 Trigger Calibration

The following instructions assume that all pre-start set-up instructions given in previous sections have been
completed. Only after all pre-start checks have been made should an attempt be made to crank the engine.
The following steps must be performed before an attempt is made to start the engine to ensure the G4AXECU
is calibrated to precisely measure engine position.

1. Connect the ECU to PCLink.

2. Select 'Fuel', then 'Fuel Set-up"

© 2020 Link Engine Management Ltd
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a. Set ‘Injection Mode’ to OFF. This will prevent the engine from trying to start while the triggers are
calibrated.
b. Perform a Store (press F4) to make sure fuelling is not re-enabled if power to the ECU is lost.
3. Click on ‘Triggers’ then ‘Calibrate Triggers’.
4. Perform the correct trigger calibration procedure specific to your vehicle as described in the PCLink help
(Press F1).
Note that trigger calibration must be performed again once the engine is running. Due to the acceleration and
deceleration of the crankshaft at low speeds, an inaccurate measurement of engine timing is usually made.
Also it is often harder to see timing marks with a timing light at slow engine speeds. Trigger calibration should
be checked again at between 2000-4000 RPM where engine speed is stable and a more consistent timing
reading can be obtained.

A more in depth explanation is provided in the PCLink help Manual under G4X ECU Tuning Functions ->
Triggers -> Calibration.

1.7 First Time Startup

After performing all set-up instructions given in previous sections, including trigger calibration, the engine is

now ready to be started. The following procedure should be used for first time start-up.

1. Turn the ignition key OFF then ON. The fuel pump should prime momentarily upon power up.

2. Connect the ECU to PCLink.

3. Access the runtimes values by pressing the F12 Key, click the 'Analog' tab:

a. TPS — spans from 0 to 100% when throttle is pressed. If not, perform a TPS Calibration.

b. MAP — should read approx 101 kPa (at sea lewel) with the engine not running. If not, check the MAP
Sensor Type setting and perform a MAP Calibration.

c. ECT - should read current engine temperature.

d. IAT - should read current intake air temperature.

e. Digital Inputs (click the 'Digital' tab) — Operate switches connected to any digital inputs while watching
the runtime value to ensure they operate as expected.

Rectify any faults found in Step 3.

5. Locate the 'Master Fuel' setting. This can be found in the ECU Settings Menu under: Fuel > Fuel Setup >
Fuel Main.

a. This will need to be adjusted during or just after start-up.

6. Crank the engine until it starts. Some throttle may be required for first time start-up due to imperfect
tuning. If necessary adjust the Master setting to enrich/lean the engine (increase to enrich).

7. If the engine fails to start after several attempts, do not crank it endlessly. Stop and determine the
problem before continuing.

8. Check the Trigger Error Counter (found under the Triggers runtime values tab). If this value increases
during cranking/running then there is a trigger setup fault. It is not unusual for this number to count one or
two on the first engine revolution.

9. Once the engine starts, adjust the ‘Master’ (under fuel settings) setting to achieve best possible running.

10. The engine should now be allowed to fully warm up. It may be necessary to readjust ‘Master’ several
times to maintain smooth running. Don'’t forget to keep an eye on engine temperature.

11. Once the engine is warmed up and running well, perform another trigger calibration (known “as setting the
base timing”).

12. Perform a Store by pressing F4.

1.7.1 Final Checks

&

To awid potential engine damage and wasted time, the adjustments presented in the following sections must
be made before attempting to start the engine.

For further help on any of the settings discussed below, consult the Help in PCLink Tuning Software. Help
can be invoked by pressing F1, or right clicking any item and selecting ‘What’s this?’.

Pre-set-up Checks

Before attempting to configure the ECU, ensure the following tasks have been completed:

1. Ensure the ECU and all associated components are connected and correctly wired/installed.

2. Fully charge the wehicle’s battery, as the engine will be required to be cranked during the set-up
procedure.
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1.7.2

3. Check all oil and water levels are correct.

Connecting to PCLink Tuning Software

Use the following procedure to establish a connection between your Link ECU and PCLink Tuning Software

tuning software.

1. Make sure your laptop battery is fully charged or plugged in to mains power.

2. Connect the ECU to your laptop and connect to PCLink as described in the '‘Communicating with your
ECU' section of this manual.

Initial Setup

After all checks described in previous sections have been performed, the ECU is ready to be configured for a
particular application. The following set-up procedure should be used on all installations as a minimum:
Configuration and Fueling Set-up
If the ECU is to be used to control fuel injection, all of the following steps must be performed. If the ECU wiill
not be controlling fuel injection, then only steps 1 and 2 are required.

1. Ifyou hawe a .pclx file containing a base configuration, this

is the time to load it into the ECU. To do this, select ‘Open’

form the ‘File’ menu. Select the required .pcix file and then

select ‘Ok’. When prompted if you want to load the file into
the ECU, select ‘Yes’.

2. Click on the ‘Configuration’ heading in the ECU Settings
function tree (top left of PCLink Tuning Software screen):

a. Select the correct engine type

b. Select the correct number of cylinders/rotors.

c. Enter the engines firing order.

3. Click on Fuel > Fuel Setup > Fuel Main:

a. Select the desired Injection Mode (e.g. Sequential or
Group).

b. Select 'Fuel Table1' from under the 'Fuel' heading. Right
click on the table, select 'Axis Setup'. Set the Y Axis
(Load) to the appropriate option (e.g. MGP or TPS).

4. Click on ‘Accel Enrichment’:
a. Turn Accel Mode OFF for first time set-ups.
5. Click on Fuel Corrections > IAT Fuel Correction:

a. [f air temperature correction is to be used and an air
temperature sensor is fitted, set the ‘IAT Mode’ to ON.
Then select and fill in the IAT Fuel Trim Table.

b. Turn OFF air temp correction (under ‘IAT Mode’) if air
temperature correction is not going to be used

6. Click on Fuel > Fuel Setup > Injector Setup:
a. Select 2D Table' or '3D Table'. Fill in the dead-time table
with the information from your injector data-sheet.

7. Click on ‘Overrun Fuel Cut’:

a. Set ‘Fuel cut Mode’ to OFF.
8. Click on Fuel Corrections > Dual Fuel Table:

a. Set Table 2 Mode' to OFF.
9. Click on Fuel Corrections > 4D Fuel Table:

a. Set ‘4D Fuel Mode’ to OFF.
10. Click on Fuel Setup > Injector Test:

a. Turn each injection channel on one by one and check
that the correct cylinders injector clicks. Fix any
problems now if the injectors do not operate.

11. Perform a Store to permanently save changes to the ECU
by pressing F4.
Ignition Set-up
If the ECU is to be used to control ignition, all of the following steps must be performed. If the ECU will not be
controlling ignition, then only the first step is required.
1. Click on Ignition > Ignition Set-up > Ignition Main:
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a. Select the correct type of ‘Ignition Mode’ for the
application. Set to 'OFF' if ignition is not controlled by
the ECU.
b. Set ‘Maximum Advance’ to a suitable value.
c. Enter appropriate values for coil dwell time in the
‘Ignition Dwell Time’ table.
2. Click on Ignition Corrections > ECT Ign Trim:
a. Set ECT Trim Mode to OFF (for now).
3. Click on ‘IAT Ign Trim’:
a. Set IAT Trim Mode to OFF (for now).
4. Click on Individual Cyl Ign Trim > Individual Cyl Ign Trim:
a. Set ‘Indivign Mode’ to OFF (for now).
5. Click on Ignition Corrections > Dual Ign Table:
a. Set Table 2 Mode to OFF (for now).
6. Click on ‘4D Ign Table":
a. Set ‘4D Ign Mode’ to OFF (for now).
7. Click on Ignition Setup > Ignition Test:
a. Turn each ignition channels test function on one by one.
b. Check for a quiet clicking sound from each coil or
alternately connect a spark gap and check for spark on
the correct cylinders.
c. Correct any problems before continuing.
8. Perform a Store to permanently save changes to the ECU
by pressing F4.
Limits Set-up
At this stage it is not necessary to precisely set all limits. However, it is essential to ensure they are set to
values that will not interfere with tuning procedures. It is advisable to err on the conservative side when setting
limit values.
1. Click on Limits > RPM Limit > RPM Limit:
a. Select the desired ‘RPM Limit Mode’
b. Select the RPM Limit Table, enter the required RPM
limiting value for each engine temperature in the ‘RPM
Limit Table’.
2. Click on Limits > MAP Limit > MAP Limit:
a. Select the desired ‘MAP Limit Mode’
b. Select the MAP Limit Table, enter the required MAP
limiting value for each engine temperature in the ‘MAP
Limit Table’.
3. Click on Limits > Speed Limit:
a. Set 'Speed Limit Switch' and 'Speed Limit Switch 2' to
'OFF' to ensure it is not invoked during tuning. Note that
this limit will only be effective if a vehicle speed sensor
is correctly wired and configured.
4. Perform a Store to permanently save changes to the ECU
by pressing F4.
Trigger Set-up
Trigger set-up requires entering information regarding the way in which engine speed and position is
measured. Consult the PCLink Tuning Software online help for further information on functions.
WARNING!
These are probably the most critical set-up values. Do not attempt to start
the engine unless you are 100% confident that these values are correct.
If trigger information is unknown, consult your nearest Link dealer for further assistance.
1. Click on ‘Triggers’ then “Trigger Set-up’:
a. Configure triggers as required.
2. Click on ‘Trigger1’:
a. Select correct trigger type and set-up completely.
3. Click on ‘Trigger2’:
a. Select correct trigger type and set-up completely.
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4. Perform a Store to permanently save changes to the ECU
by pressing F4.
Additional Set-up
It is important that all features not required for initial tuning are either disabled or correctly set-up. It is
recommended that features be initially disabled to ensure they do not complicate tuning.
1. Click on ‘Motorsport’ then ‘Antilag’:
a. Set ‘Antilag Mode’ to OFF.
2. Click on ‘Launch Control’:
a. Set ‘Launch Control Mode’ to OFF..
3. Click on 'Gear Cut Control’:
a. Set 'Gear Cut Control Mode’ to OFF.
4. Click on Boost Control > Boost Set-up:
a. Configure Boost Control as described in the PCLink
Tuning Software online help.
5. Click on 'Multiple Boost Tables":
a. Set 'Active Tables' to 1 Table.
6. Perform a Store to permanently save changes to the ECU
by pressing F4.

1.7.3 Essential Tuning Adjustments

It is assumed that at this stage all set-up procedures described in previous sections have been completed
and the engine is running.The following steps detail correct set-up procedures for some of the more critical
ECU parameters (note that MAP Sensor Calibration should have already been completed by now):

Injector Voltage (Dead-time) Correction

There is always a delay between the injector being energised and the injector actually opening. Likewise,
there is a small delay between the injector being de-energised and the injector closing. The opening time is
considerably longer than the closing time, however the overall result is that less fuel will flow for a given pulse
width than would be expected with an ‘ideal injector'. To compensate for this the injector pulse widths are
increased to compensate for this 'dead-time'. The dead-time for a given injector is a function of the battery
woltage, differential fuel pressure and the type of injector driver (saturated or peak and hold). A typical dead-
time at 3 Bar differential fuel pressure and 14 wolts is just under 1ms (ms = millisecond = 1 thousandth of a
second).

In applications with a linear 1:1 fuel pressure regulator (i.e. not a rising rate regulator), the differential fuel
pressure (difference between manifold pressure and fuel pressure) will be constant. Therefore the only variable
that is changing will be the battery wltage (this changes with electrical load and sometimes engine speed).
Without correction, the changes in dead-time will cause the engine to run lean when the woltage drops. If the
Injector Voltage Correction is properly set-up then changes in the battery voltage will not affect the air/fuel
ratio.

The injector dead-time table allows the dead-time for different battery woltages to be entered. The values
represent the dead-time in milliseconds. These should increase with falling system voltage.

Injector dead-time for a particular set of injectors can be determined using a flow bench or on a running
engine.

To determine the injector dead-time using a flow bench, the injectors need to be operated at the intended
operating pressure (normally three bar) and at a constant duty cycle as well as a set wltage. Vary the supply
woltage to the injector and measure minimum pulse width at which the injectors will flow for a particular
woltage. This is the required dead-time for that injector at that tested woltage.

To determine injector dead-time on a running engine, with the engine fully warmed and operating at stable
air/fuel ratios (a very precise AFR meter is required — a narrow band O2 sensor will not suffice), electrical
drain needs to be applied to the system; the preferred method is disconnecting the alternator main fuse.
Battery load testers are also useful here too.

Watching the air fuel ratios change while the battery wvoltage drops, the dead-time table can be trimmed to
maintain the same stable air/fuel ratio. Injector dead-time can be viewed as a row graph. A smooth curve
needs to be maintained at all times.

NOTE: any change to the fuel pressure or injectors will require a recalibration of the injector dead-times.

Master
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Master should be set so that the numbers in the middle of the fuel table end up around a value of 50. This is
to allow sufficient span of the numbers in the main fuel table.

1.8 Pinouts
Pin information is provided to assist when troubleshooting. All pinouts are looking into the ECU (wire side).

1.8.1 MR2Link V1
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Pin ECU Pin Function Pin ECU Pin Function
1(B13) Ground 44 (C11) An Volt 2 TPS Signal
2 (B12) Injector 1 Injection 45 (C10) An Temp 3 Spare
3(B11) Injector 2 Injection 46 (C9) Ground (Signal)

4 (B10) nc
5 (B9) Aux 1 ISC Open 51 (A11) DI 1 Start Signal
6 (B8) | Injector 6 (Aux) Oxy Heater 52 (A10) Dl 2 A/C Request
7 (B7) nc 53 (A9) DI 3 Vehicle Speed
8 (B6) Aux 3 Wastegate Solenoid 54 (A8) nc
9 (B5) nc 55 (A7) nc
10 (B4) nc 56 (AB) Aux 4 Fuel Pump Speed
11 (B3) nc 57 (A5) Aux 8 CE Light
12 (B2) nc 58 (A4) nc
13 (B1) Trig 1 Trig 1 (NE) 59 (A3) nc
14 (B26) Ground 60 (A2) nc
15 (B25) Injector 3 Injection 61 (A1) nc (+12V constant)
16 (B24) Injector 4 Injection 62 (A22) nc
17 (B23) | Injector 5 (Aux) EGR 63 (A21) Aux 6
18 (B22) Aux 2 ISC Close 64 (A20) nc
19 (B21) nc 65 (A19) nc
20 (B20) Ignition 1 Ignition 66 (A18) nc
21 (B19) nc 67 (A17) nc
22 (B18) Aux 5 TVIS 68 (A16) nc
23 (B17) Aux 7 Fuel Pump Relay 69 (A15) nc
24 (B16) nc 70 (A14) nc
25 (B15) Trig 2 Trig 2 (G1) 71 (A13) +14V ECU Power
26 (B14) | Ground(Signal) 72 (A12) +14V ECU Power
31 (C8) nc Expansion 1| Ground (Signal)
32 (C7) nc Expansion 2 +5V Out
33 (C6) An Volt 1 Oxy Signal Expansion 3 DI 5
34 (C5) Knock 1 Knock Expansion 4 DI 6
35 (C4) An Temp 1 ECT Expansion 5 Dl 4
36 (C3) An Temp 2 AFM IAT (ambient Expansion 6 An Volt 4
temp)
37 (C2) An Volt 4 AFM Expansion 7 An Volt 5
38 (C1) +5V Out Expansion 8 An Volt 6
39 (C16) | Ground (G-)
40 (C15) nc Ignition 2 Spare
41 (C14) nc Ignition Ignition 1 Ignition
42 (C13) An Volt 3 MAP (Factory Sensor) | Expansion Ignition 3 Spare
43 (C12) nc Ignition 4 Spare

Note: On the mr2 AC request is actually just from, the AC clutch, not the push button.

Note: Injector Drives 7 and 8 aren't exposed and don't have the hardware required to drive Injectors.
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1.9 CAN Information

The following CAN (Controller Area Network) information is provided:

1.9.1 MR2Link V1

The G4X MR2Link V1 Plug-in ECU has one CAN bus. This CAN bus exists to support aftermarket CAN

devices.

CAN bus 1 uses a 5 pin connector and is labeled on the ECU as 'CAN 1/RS232".
If using this connector for CAN ensure the cable being used doesn't have Serial wires connected as this can
act as an aerial and prevent USB communications from working.

CAN 1/RS232 Connector
Pin Function Colour
1 Comms GND (Brown
2 CAN1L Green
3 CAN1H White
4 RS232-RX Grey
5 RS232-TX Yellow

To learn more about CAN see PCLink help.

1.10 Known Issues

19

All plug-in ECUs are fully tested on a range of relevant wehicles, although there are often variations that have

not been tested. For this reason issues can arise.

WARNING: Always download the latest Installation Manual from linkecu.com and check the latest status of

known issues before installing the ECU.

Please contact your nearest Link dealer when suspecting a compatibility issue.

1.10.1 MR2Link V1

There are currently no known issues.
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