WRXLink (04) - Subaru WRX & STI
V10 04-06 and WRXLink (07) Subaru WRX & STI V10 06-07

Product Warranty Statement
LINK ENGINE MANAGEMENT LTD – LIMITED LIFETIME WARRANTY
All Engine Control Units (ECUs) manufactured or distributed by Link Engine Management Ltd are
subject to the following LIMITED LIFETIME WARRANTIES, and no others.
Link Engine Management Ltd warrants only to the original purchaser of the ECU, for the lifetime of
the ECU, (subject to the limitations set out below), that the ECU shall be free from defects of
materials and workmanship in the manufacturing process. This warranty ceases to apply and does
not apply to ECUs that have not been manufactured or distributed by Link Engine Management Ltd
for a period of greater than one year.
An ECU claimed to be defective must be returned to the place of purchase. Link Engine Management
Ltd, at its sole option, may replace the defective ECU with a comparable new ECU or repair the
defective ECU.
This limited lifetime warranty is not transferable and does not apply to any ECU not properly installed
or properly used by the purchaser or end user, or to any ECU damaged or impaired by external
forces. The above warranties are the full extent of the warranties available on the ECU. Link Engine
Management Ltd has no liability to the original purchaser or any other person for any loss, injury or
damage to persons or property resulting from the use of the ECU or any failure of or defect in the
ECU whether by general, special, direct, indirect, incidental, consequential, exemplary, punitive, or
any other damages of any kind or nature whatsoever. Link Engine Management Ltd specifically
disclaims and disavows all other warranties, express or implied, including, without limitation, all
warranties of fitness for a particular purpose, warranties of description, warranties of merchantability,
trade usage or warranties of trade usage.
For off-road use only, not intended for highway vehicles. This ECU contains a user-configurable
software programme, which is updated by Link Engine Management Ltd from time to time. The user
must ensure the current correct version of this programme is downloaded from the website of Link
Engine Management Ltd and installed in the ECU prior to use. This limited lifetime warranty does not
apply where the ECU has been installed with the incorrect version of the software programme. The
user is solely responsible for the setup and testing of all user-configurable features.
Link Engine Management Ltd License Agreement
The software programme in this ECU is licensed not sold. Link Engine Management Ltd grants the
user a license for the programme only in the country where the programme was acquired. No other
rights are granted under this license and the programme may only be used on one machine at a
time. If the programme is transferred a copy of this license and all other documentation must be
transferred at the same time. The license may be terminated by the user at any time. Link Engine
Management Ltd may terminate the licence if the user fails to comply with the terms and conditions
of this license. In either event the copy of the programme must be destroyed.
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1.1

Introduction
Thank you for purchasing your Link Plug-In Engine Control Unit (ECU), an advanced, fully programmable
microprocessor controlled Engine Management System.
G4X software employs high resolution fuel and ignition tables with configurable load and RPM centres. When
coupled with up to six dimensional fuel and ignition mapping, barometric pressure compensation and intake
air temperature correction this gives an unprecedented level of tuning accuracy. All Link G4X ECUs are in-field
upgradeable, there is no need to return the unit for software updates.
All Link G4X Plug-In Engine Management Systems are designed with flexibility and ease of installation in
mind. Link Plug-In systems are designed to replace the circuit board inside the factory ECU enclosure. This
provides an invisible install that requires minimal modification to vehicle wiring and ECU mounting.
Installing and tuning any after market engine management system is not to be taken lightly. G4X ECUs give
the tuner the control & flexibility that only top after-market engine management systems in the world can
provide. While every effort has been made to keep G4X ECUs as user friendly as possible, it should be
recognised that added features bring added complexity.
The complete setup of your ECU can be divided into two important tasks:
1. This manual covers the installation of your G4X ECU. While it is not strictly essential that this work is
performed by an automotive electrician, the knowledge and tools available to these professionals makes it
highly recommended. Regardless of who does the installation, it is of utmost importance that instructions
provided in this manual are followed exactly throughout the installation.
2. Once the G4X ECU has been installed it will need to be tuned using a laptop computer with PCLink
software. Information on the configuration and tuning of the G4X ECU is detailed in the help section of
PCLink. G4X ECUs are shipped pre-loaded with a base configuration that should be close enough to get
most engines running after a few application specific adjustments have been made. While hearing the
engine running on the new ECU for the first time is always a satisfying feeling, it is important to realise
that the job is not complete. The amount of tuning performed and the experience of the tuner are the two
most important factors in determining how happy you will be with your engine management system.

1.1.1

Safety Notice
Your Link Plug-In ECU is designed to enhance the performance of your vehicle. However in all cases, your
vehicle must be operated in a safe manner. Do not tune your vehicle while operating it on public roads.
WARNING!
Failure to follow all installation and operating instructions may result in damage to
the Link ECU, personal injury, or harm to property.

1.1.2

Disclaimer
All care has been taken to ensure the pin outs and interconnections of the ECU to the vehicles wiring harness
are correct. However due to variations between vehicle models it is the installers responsibility to check wiring
connections BEFORE installing the ECU. Link will not be held responsible for any damage caused by the
incorrect installation of this product.

1.1.3

Support Options
Should any issues arise during installation, the following options exist for technical support:
1. PCLink help, press F1 while running PCLink
2. Contact your nearest Link dealer. A Link dealer list is available on our website.
3. Link website: www.linkecu.com with Online Discussion Forum.
4. Technical Support Email: tech@linkecu.com
The majority of questions received by the technical support team are clearly answered in the manuals. Please
consult the manuals to make sure that your question has not already been answered.

1.2

Pre-Installation
Before installing the Link G4X ECU into the vehicle some pre-installation checks must be performed.

© 2020 Link Engine Management Ltd

G4X Plug-In ECU Installation Manual

1.2.1

7

Compatibility Check
It is essential that a compatibility check is performed before installing the ECU into the vehicle. Failure to do
so may void the warranty. There are some cases where the same ECU connector is used on very similar
vehicle models but with a completely different pinout.

1.2.1.1

WRXLink (10)
There are two different Subaru Impreza WRX V10 ECUs available. These are categorised as 2004-2006
2500cc and 2007 2500cc. This maybe slightly misleading as some 2006 vehicles require a 2007 ECU.
It is critical that the correct ECU for the vehicle is installed, failure to install the correct ECU can
result in engine component, engine wiring or ECU damage.
The correct ECU can be verified by studying the wiring loom.
If pins A1, A2 and A3 (see pinout section) contain no wires, then the correct ECU required is the 2007
2500cc version. If these pins contain wires, then the correct ECU is the 2004-2006 2500cc version.

1.2.2

Board Switch Settings
Some Link G4X ECUs require switches on the board to be set before installation.

1.2.2.1

WRXLink (10)
There are jumpers located on the circuit board inside the case. These jumpers configure changes Subaru
made between years.
The jumpers MUST be set before installing the adapter in the vehicle.

When the jumper consists of three pins in a row,
correct selection is made by moving the jumper to
the appropriate end of the three pins.

When the jumper consists of four pins in a
square, correct selection is made by positioning
the two jumpers in either vertical or horizontal
orientation.

Information regarding the correct jumper position for the vehicle is printed on the PCB.
To access the jumpers, one end plate must be removed from the case and the PCB will slide out. Ensure the
adapter is fully unplugged before removing the end plate.

1.2.3

Injector Impedance
Injector impedance is important and needs consideration before installing the ECU.

1.2.3.1

Subaru Impreza WRX V1-10 ECU
The G4X Subaru V1-10 Plug-In ECUs are NOT designed to be used directly with low impedance injectors.
All models this ECU is designed for are fitted with high impedance injectors from factory. This ECU has been
designed to be used with HIGH impedance (greater than 6 Ohms) injectors. Ballast resistors must be wired if
low impedance injectors are to be used. This means that the ECU is plug-in compatible with factory fitted
injector combinations on all models, however if fitting low impedance injectors then ballast resistors must be
wired. Contact your nearest Link dealer to purchase a ballast resistor pack if required.
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Installation
This guide provides information on correctly and safely installing your new Link G4X Plug-In ECU.

1.3.1

ECU Handling Procedures
WARNING!!!
The following installation process will require handling of both the Link ECU and
factory ECU. Both of these are highly sensitive to electrostatic discharge and are
easily damaged. Follow the anti-static precautions given in this manual carefully
to avoid damaging electronic components. Warranty claims for ECUs damaged by
electrostatic discharge will NOT be accepted.

ANTI-STATIC HANDLING GUIDELINES

Your body builds up an electrical charge as you move around. This charge can reach very high
voltages. Whenever given the opportunity this energy will attempt to discharge (usually through
your finger tips!). This can be fatal to most electronic components. Most people have
experienced an electrostatic discharge when they step out of their car or touch a metal bench
top.
1. The following guidelines describe precautions that can be taken to reduce the possibility of
damaging your ECU:
2. Work only on a conductive surface. A clean steel bench is suitable.
3. Always wear a wrist strap that is electrically connected to the conductive working surface.
4. Touch the working surface regularly.
5. Do NOT touch components on the circuit board.
6. Where possible, only handle the ECU by its plastic header.
7. Do NOT carry the ECU around without anti-static packaging.
8. Do NOT touch the bare terminals in the ECU header.
Observing the above procedures will minimise the chance of damaging the ECU. Note that
failure due to static damage often does not appear until well after it was caused.

1.3.2

Fitting the ECU
Information is provided to assist in fitting the ECU into the vehicle.

1.3.2.1

WRXLink (04) and WRXLink (07)
The following steps outline the installation procedure for Subaru Plug-In ECUs:
1. Remove the factory ECU from the vehicle: Ensure the key is in the OFF position. The factory ECU is
located under a steel cover on the passengers side floor (below the passengers feet). Lift the carpet,
remove the cover panel. Unplug the wiring harness from the factory ECU. Remove the 6mm bolts (10mm
socket) that retain the ECU and remove the ECU from the vehicle. DO NOT touch the exposed pins in the
factory ECU connector.
2. Remove the factory ECUs circuit board from its enclosure: Ensure you are following the given anti-static
guidelines and ARE WEARING A CONDUCTIVE WRIST STRAP connected to a conductive working
surface. Remove the top and cover from the ECU enclosure by removing the side retaining screws.
Remove the circuit board by removing the retaining screws. Hold it only by the plastic header and place it
aside.
3. Fit the Link Plug-In ECU: Remove the ECU from its packaging and place it immediately in the factory
enclosure. Place the factory ECU in the packaging your Link ECU came in for its protection.
© 2020 Link Engine Management Ltd
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Note: The G4X WRXLink (04) Plug-in ECU can fit two case sizes. If the ECU PCB is too large for the case,
carefully snap the PCB extensions off at the lines shown in the image below.

4. If the ECUs USB tuning cable is to be left permanently connected, a slot will need to be cut in the top
cover. The best place to do this is usually beside the factory header.
5. Reassemble the enclosure and fit the ECU back to the vehicle.
6. Connect the ECU to the factory wiring loom.
7. Do NOT attempt to start the vehicle. Proceed to read through the remaining sections of this manual first.

1.4

Additional Sensors/Functions
G4X Plug-In ECUs offer various options for the installation of additional sensors and devices. As a minimum it
is recommended that all ECUs are installed with a Manifold Absolute Pressure (MAP) sensor and Intake Air
Temperature (IAT) sensor. These parts can be purchased if required from your nearest Link dealer.

1.4.1

MAP Sensor
It is important that the pressure source for a MAP sensor be taken from a stable pressure source after the
throttle body. It is common to 'T' into the fuel pressure regulators pressure signal. Do NOT share this signal
with other devices such as boost gauges or blow off valves.

1.4.1.1

WRXLink (04) & WRXLink (07)
The Link G4X WRXLink (04) & WRXLink (07) plugins support several options for fitting of a MAP sensor, any
one of the following options can be used:
1. Factory MAP Sensor – From factory, all models supported by this ECU are fitted with a factory MAP
sensor. The factory MAP sensor is wired to An Volt 1. The factory sensor is good for 160kPa (23psi) of
boost.
2. Factory MAP Sensor Upgrade – The factory MAP sensor can be upgraded by simply replacing the factory
MAP sensor. Contact your nearest Link dealer for upgrade options.
Make sure that the correct MAP sensor input has been selected in PCLink and a MAP calibration has been
performed before attempting to start the vehicle.
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IAT Sensor
It is highly recommended that an IAT sensor be fitted in all applications to provide an input for correction of
fuel and ignition based on the engines air charge temperature.
An IAT sensor should be fitted in the intake system in a location that accurately represents intake
temperature. The most common location is just prior to the throttle body. Installing in the manifold is not
recommended due to heat soak issues. A fast response sensor must be used in all forced induction
applications.

1.4.2.1

WRXLink (04) and WRXLink (07)
The AFM has a factory fitted IAT sensor. Due to its location this sensor is not suitable for tuning. A suitable
IAT sensor can however be wired to the AFM wiring. The AFMs IAT signal is wired to An Temp 2. Factory
AFM wiring information follows:

1 +14V
2 Ground
3 Mass Air Flow Meter
4 Intake Air Temperature
5 Ground
Note: It is important that the factory IAT sensor is completely disconnected as not to affect the after market
IAT sensor signal.
An IAT sensor can also be wired in using any spare An Temp or An Volt pin (several are available on the
expansion connectors). Note spare An Volt channels require a pullup resistor (to +5V) to be added for
temperature input use.

1.4.3

E-Throttle Output
It is becoming more common to convert cable throttle vehicles to Electronic Throttle control, this section
explains how (if it is possible) to do this for each plugin.

1.4.3.1

WRXLink (04) and WRXLink (07)
This vehicle has E-Throttle from factory and so does not require any modifications.
The E-Throttle Output pins are Aux 9 & 10 and the EThrottle Relay is Aux Ignition 8. If the EThrottle is found
to be operating in the wrong direction this can be rectified by changing the Aux 9 Active State (Electronic
Throttle -> E-Throttle 1 -> E-Throttle Setup or by swapping the +ve and -ve pins at the throttle plug.

1.4.4

Expansion Connector
Expansion connectors are provided to allow easy connection of additional ECU inputs. An “expansion cable”
can be purchased from your Link dealer.
Important points when wiring to the expansion connector:
· Do not overload the +5V Out pin. Although this is protected against ECU damage the +5V out signal also
provides power for other sensors.
· Do not connect the ground pin to chassis ground. This could cause ground loops and introduce
unnecessary interference. Use this pin only to ground external sensors that are isolated from chassis
ground.
The Expansion connectors available for each ECU can be found under the Pinouts Section.
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PC Tuning
G4X ECUs require PC/laptop tuning using the PCLink Tuning Software application running on a Windows
based computer. PCLink may be downloaded from www.linkecu.com. Note that when new versions of PCLink
are released they are posted on the website and may be downloaded at no cost. Also note that G4X ECUs
must be used with the correct version of PCLink.
IMPORTANT!
The G4X ECU has on board USB.
BEFORE connecting the ECU to your laptop, the USB drivers must be installed.
Failure to install the drivers on your laptop first may result in windows assigning
incorrect drivers. These drivers will not work with the G4X ECU and are difficult to
uninstall. The correct USB drivers are installed as part of PCLink installation, as
described in the following section. Should internet download not be practical, a
copy of the drivers on CD can be obtained from your nearest Link dealer.

1.5.1

Installing USB Drivers
Before connecting the ECU to your laptop or PC, the ECU USB drivers must be installed. These drivers are
installed as part of PCLink installation as described in the following section. Should internet download not be
practical, a copy of the drivers on CD can be obtained from your nearest Link Dealer.

1.5.2

Installing PCLink Tuning Software
Due to the frequent updates PCLink is no longer shipped with each ECU. You will be required to download the
latest version of PCLink from: linkecu.com
Should access to an Internet connection be impractical, download the latest version of PCLink elsewhere to a
USB drive, and then install on your laptop.
Installing from the web
1. Go to the above website and navigate to the downloads and software updates section.
2. Download the latest version of PCLink. When prompted to run or save the file, select save. It is
recommended to save this file on the desktop.
3. Double click the saved file and follow on screen instructions.
4. When prompted to install USB drivers, select yes. This may take some time.
5. When installed, open PCLink by double clicking on the icon that has been placed on the desktop.

1.5.3

Communicating With Your ECU
After PCLink installation, you will be able to connect the G4X ECU to the laptop to perform set-up and tuning
work.
1. Connect the ECU to your laptop using a Link G4X ECU USB Cable. If not supplied with the ECU, these
can be purchased from a Link dealer. No other adapter or cabling is required. Connect the cable to the
connector labelled USB.
2. If this is the first time you have connected a G4X USB ECU to your laptop follow the driver installation
instructions that appear. When prompted if you want to install drivers select 'Continue Anyway'.
3. Start PCLink by double clicking on the PCLink icon on the windows desktop.
4. Switch the key to the ON position. This will provide power to the ECU.
5. In PCLink, under the 'Options' menu, select 'Connection'. The connection options dialogue will open.
Select the correct COM Port number from the drop down list or select auto for automatic com port
detection.
6. PCLink offers both mouse and keyboard control. To establish a connection between the PC and ECU
press the F3 key. The same process can be used to disconnect. If a successful connection is
established, PCLink will download settings from the ECU, otherwise you will be warned that an error has
occurred.
7. Make sure the connection shows “ONLINE” in the top right corner of PCLink.
8. To permanently STORE any changes made to the ECU press F4. If this is not done before turning the
ECUs power off all changes made will be lost.
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Pre-Start Configuration
Before starting the vehicle, important pre-start configurations need to be made.

1.6.1

Firmware Version
It is recommended to ensure that the Link G4X ECU is running the most up to date firmware. Firmware
version information can be obtained by connecting to the ECU with PCLink and selecting 'ECU Information'
under the Help menu.
The latest firmware can be downloaded from our website with PCLink.
It is recommended that this is performed by an experienced Link dealer as new features may need to be
properly configured.
The firmware can be updated by selecting 'Update Firmware' under the 'ECU Controls' menu in PCLink, follow
the on screen instructions to complete the firmware update process.

1.6.2

Base Configuration
All G4X Plug-In ECUs are shipped with base configuration settings. Note that these are provided to reduce
initial setup and tuning times. They are NOT recommended tuning values. PCLink includes base
configurations for various models. Download the appropriate base configuration into your ECU with PCLink by
connecting to the ECU (described in the Connecting To PCLink section of this manual), then selecting 'Open'
under the 'File' menu. Select the appropriate .pclx file and then select 'Open'. Downloading large configuration
files can take up to a few minutes. Be patient and acknowledge any messages PCLink shows.

1.6.3

MAP Sensor Calibration
At key on and engine not running the Manifold Absolute Pressure (MAP) Sensor should always match the
Barometric Absolute Pressure (BAP) Sensor. As well as providing altitude correction, the BAP sensor also
allows the MAP sensor to be calibrated prior to tuning.
Link G4X ECUs use an on-board barometric sensor that is calibrated prior to dispatch. This ensures that all
PCLink Tuning Software programs (pclx Files) give a consistent state of tune throughout the ECU range. This
allows a pclx file to be transferred between G4X based ECUs giving an equivalent state of tune providing all
factors affecting volumetric efficiency are equal.
Without the ability to calibrate all the available types of MAP Sensors to the BAP Sensor there would be
significant affects on the accuracy of the resulting tune, especially when tuning with Manifold Gauge Pressure
(MGP) as a load index.
To calibrate the MAP sensor:
1. Connect a laptop/notebook PC to the ECU and connect to the ECU using PCLink.
2. Under the Analog Channels menu, select the An Volt channel that has been wired to the MAP sensor.
Select the correct MAP Sensor Type.
3. Under the 'Options' menu, select 'MAP sensor calibration'.
4. Follow the on screen instructions.
5. Select the 'Analog Inputs' tab in the runtime values section of PCLink (lower part of the screen).
6. Compare the MAP and BAP values and ensure they have a similar reading (within 1 kPa).
7. Perform a 'Store' by pressing F4.
A more in depth explanation is provided in the PCLink help Manual under PCLink G4X Users Manual ->
Tuning Operating Procedures -> ECU Controls -> MAP Sensor Calibration.

1.6.4

TPS Calibration
The Throttle Position Sensor (TPS) is used by the ECU to calculate various engine management parameters
used by functions such as idle speed control,acceleration enrichment and motor sport features. It is important
that the ECU knows when the throttle is open and closed (or part way in between). The following procedure
calibrates the ECU to match the TPS and is for engines using a cable driven throttle:
1. Connect a laptop/notebook PC to the ECU and connect to the ECU using PCLink.
2. Under the Analog Channels menu, ensure that the correct An Volt channel is set to 'TPS (Main)'. Refer to
the pin functions section of this manual for details.
3. Under the 'Options' menu, select 'TPS calibration'.
4. Follow the on screen instructions.
5. Select the 'Analog Inputs' tab in the runtime values section of PCLink (lower part of the screen).
© 2020 Link Engine Management Ltd
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6. Ensure the Throttle Position value reads 0% when the throttle is closed and 100% when fully open.
7. Perform a 'Store' by pressing F4.
For engine setups that use Electronic Throttle Control the Accelerator Position Sensor (APS) and Throttle
Position Sensor (TPS) need to be calibrated.
For Link Plug-in ECUs see PCLink Help > G4X ECU Tuning Functions > Electronic Throttle Control

1.6.5

IAT Sensor Selection
This section only applies when an Intake Air Temperature (IAT) sensor has been wired and fitted to the intake
system. It is important that the ECU is calibrated to match the sensor installed in the engine. This procedure
is as simple as selecting the correct sensor type as follows:
1. Connect a laptop/notebook PC to the ECU and connect to the ECU using PCLink.
2. Click on 'Analog Channel' in the configuration tree.
3. Select the An Temp channel the sensor has been wired to.
4. Ensure that channel (and only that channel) is set to 'Inlet Air Temperature'.
5. Select the correct 'Temp Sensor Type'.
6. Select the 'Analog Inputs' tab in the runtime values section of PCLink (lower part of the screen).
7. Ensure that IAT reads the correct temperature.
8. Perform a 'Store' by pressing F4.

1.6.6

Input and Output Setup
As the Link G4X Plug-In ECUs are designed to run several models there are a few items that must be set-up
to make the ECU specific to your model.
The Pin Functions section of this manual gives a list of the functions of each channel based on the target
vehicle.
It is the tuners responsibility to make sure that the following channels are set-up correctly for the vehicle
model the ECU is fitted to:
All Auxiliary Output Channels
Use the 'Test On' or 'Test PWM' (at 10 Hz) functions to test the wiring of channels.
All Digital Inputs
Look at the Digital Inputs runtime values (lower section of the PCLink screen) to confirm each channels
operation.
All Analog Volt and Temperature Inputs
Look at the Analog Inputs runtime values (lower section of the PCLink screen) to confirm each channels
operation.

1.6.7

Trigger Calibration
The following instructions assume that all pre-start set-up instructions given in previous sections have been
completed. Only after all pre-start checks have been made should an attempt be made to crank the engine.
The following steps must be performed before an attempt is made to start the engine to ensure the G4X ECU
is calibrated to precisely measure engine position.
1. Connect the ECU to PCLink.
2. Select 'Fuel', then 'Fuel Set-up':
a. Set ‘Injection Mode’ to OFF. This will prevent the engine from trying to start while the triggers are
calibrated.
b. Perform a Store (press F4) to make sure fuelling is not re-enabled if power to the ECU is lost.
3. Click on ‘Triggers’ then ‘Calibrate Triggers’.
4. Perform the correct trigger calibration procedure specific to your vehicle as described in the PCLink help
(Press F1).
Note that trigger calibration must be performed again once the engine is running. Due to the acceleration and
deceleration of the crankshaft at low speeds, an inaccurate measurement of engine timing is usually made.
Also it is often harder to see timing marks with a timing light at slow engine speeds. Trigger calibration should
be checked again at between 2000-4000 RPM where engine speed is stable and a more consistent timing
reading can be obtained.
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A more in depth explanation is provided in the PCLink help Manual under G4X ECU Tuning Functions ->
Triggers -> Calibration.

1.7

First Time Startup
After performing all set-up instructions given in previous sections, including trigger calibration, the engine is
now ready to be started. The following procedure should be used for first time start-up.
1. Turn the ignition key OFF then ON. The fuel pump should prime momentarily upon power up.
2. Connect the ECU to PCLink.
3. Access the runtimes values by pressing the F12 Key, click the 'Analog' tab:
a. TPS – spans from 0 to 100% when throttle is pressed. If not, perform a TPS Calibration.
b. MAP – should read approx 101 kPa (at sea level) with the engine not running. If not, check the MAP
Sensor Type setting and perform a MAP Calibration.
c. ECT – should read current engine temperature.
d. IAT – should read current intake air temperature.
e. Digital Inputs (click the 'Digital' tab) – Operate switches connected to any digital inputs while watching
the runtime value to ensure they operate as expected.
4. Rectify any faults found in Step 3.
5. Locate the 'Master Fuel' setting. This can be found in the ECU Settings Menu under: Fuel > Fuel Setup >
Fuel Main.
a. This will need to be adjusted during or just after start-up.
6. Crank the engine until it starts. Some throttle may be required for first time start-up due to imperfect
tuning. If necessary adjust the Master setting to enrich/lean the engine (increase to enrich).
7. If the engine fails to start after several attempts, do not crank it endlessly. Stop and determine the
problem before continuing.
8. Check the Trigger Error Counter (found under the Triggers runtime values tab). If this value increases
during cranking/running then there is a trigger setup fault. It is not unusual for this number to count one or
two on the first engine revolution.
9. Once the engine starts, adjust the ‘Master’ (under fuel settings) setting to achieve best possible running.
10. The engine should now be allowed to fully warm up. It may be necessary to readjust ‘Master’ several
times to maintain smooth running. Don’t forget to keep an eye on engine temperature.
11. Once the engine is warmed up and running well, perform another trigger calibration (known “as setting the
base timing”).
12. Perform a Store by pressing F4.

1.7.1

Final Checks
To avoid potential engine damage and wasted time, the adjustments presented in the following sections must
be made before attempting to start the engine.
For further help on any of the settings discussed below, consult the Help in PCLink Tuning Software. Help
can be invoked by pressing F1, or right clicking any item and selecting ‘What’s this?’.
Pre-set-up Checks
Before attempting to configure the ECU, ensure the following tasks have been completed:
1. Ensure the ECU and all associated components are connected and correctly wired/installed.
2. Fully charge the vehicle’s battery, as the engine will be required to be cranked during the set-up
procedure.
3. Check all oil and water levels are correct.
Connecting to PCLink Tuning Software
Use the following procedure to establish a connection between your Link ECU and PCLink Tuning Software
tuning software.
1. Make sure your laptop battery is fully charged or plugged in to mains power.
2. Connect the ECU to your laptop and connect to PCLink as described in the 'Communicating with your
ECU' section of this manual.

1.7.2

Initial Setup
After all checks described in previous sections have been performed, the ECU is ready to be configured for a
particular application. The following set-up procedure should be used on all installations as a minimum:
Configuration and Fueling Set-up
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If the ECU is to be used to control fuel injection, all of the following steps must be performed. If the ECU will
not be controlling fuel injection, then only steps 1 and 2 are required.
1. If you have a .pclx file containing a base configuration, this
is the time to load it into the ECU. To do this, select ‘Open’
form the ‘File’ menu. Select the required .pclx file and then
select ‘Ok’. When prompted if you want to load the file into
the ECU, select ‘Yes’.
2. Click on the ‘Configuration’ heading in the ECU Settings
function tree (top left of PCLink Tuning Software screen):
a. Select the correct engine type
b. Select the correct number of cylinders/rotors.
c. Enter the engines firing order.
3. Click on Fuel > Fuel Setup > Fuel Main:
a. Select the desired Injection Mode (e.g. Sequential or
Group).
b. Select 'Fuel Table1' from under the 'Fuel' heading. Right
click on the table, select 'Axis Setup'. Set the Y Axis
(Load) to the appropriate option (e.g. MGP or TPS).
4. Click on ‘Accel Enrichment’:
a. Turn Accel Mode OFF for first time set-ups.
5. Click on Fuel Corrections > IAT Fuel Correction:
a. If air temperature correction is to be used and an air
temperature sensor is fitted, set the ‘IAT Mode’ to ON.
Then select and fill in the IAT Fuel Trim Table.
b. Turn OFF air temp correction (under ‘IAT Mode’) if air
temperature correction is not going to be used
6. Click on Fuel > Fuel Setup > Injector Setup:
a. Select '2D Table' or '3D Table'. Fill in the dead-time table
with the information from your injector data-sheet.
7. Click on ‘Overrun Fuel Cut’:
a. Set ‘Fuel cut Mode’ to OFF.
8. Click on Fuel Corrections > Dual Fuel Table:
a. Set Table 2 Mode' to OFF.
9. Click on Fuel Corrections > 4D Fuel Table:
a. Set ‘4D Fuel Mode’ to OFF.
10. Click on Fuel Setup > Injector Test:
a. Turn each injection channel on one by one and check
that the correct cylinders injector clicks. Fix any
problems now if the injectors do not operate.
11. Perform a Store to permanently save changes to the ECU
by pressing F4.
Ignition Set-up
If the ECU is to be used to control ignition, all of the following steps must be performed. If the ECU will not be
controlling ignition, then only the first step is required.
1. Click on Ignition > Ignition Set-up > Ignition Main:
a. Select the correct type of ‘Ignition Mode’ for the
application. Set to 'OFF' if ignition is not controlled by
the ECU.
b. Set ‘Maximum Advance’ to a suitable value.
c. Enter appropriate values for coil dwell time in the
‘Ignition Dwell Time’ table.
2. Click on Ignition Corrections > ECT Ign Trim:
a. Set ECT Trim Mode to OFF (for now).
3. Click on ‘IAT Ign Trim’:
a. Set IAT Trim Mode to OFF (for now).
4. Click on Individual Cyl Ign Trim > Individual Cyl Ign Trim:
a. Set ‘Indiv Ign Mode’ to OFF (for now).
5. Click on Ignition Corrections > Dual Ign Table:
a. Set Table 2 Mode to OFF (for now).
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6. Click on ‘4D Ign Table':
a. Set ‘4D Ign Mode’ to OFF (for now).
7. Click on Ignition Setup > Ignition Test:
a. Turn each ignition channels test function on one by one.
b. Check for a quiet clicking sound from each coil or
alternately connect a spark gap and check for spark on
the correct cylinders.
c. Correct any problems before continuing.
8. Perform a Store to permanently save changes to the ECU
by pressing F4.
Limits Set-up
At this stage it is not necessary to precisely set all limits. However, it is essential to ensure they are set to
values that will not interfere with tuning procedures. It is advisable to err on the conservative side when setting
limit values.
1. Click on Limits > RPM Limit > RPM Limit:
a. Select the desired ‘RPM Limit Mode’
b. Select the RPM Limit Table, enter the required RPM
limiting value for each engine temperature in the ‘RPM
Limit Table’.
2. Click on Limits > MAP Limit > MAP Limit:
a. Select the desired ‘MAP Limit Mode’
b. Select the MAP Limit Table, enter the required MAP
limiting value for each engine temperature in the ‘MAP
Limit Table’.
3. Click on Limits > Speed Limit:
a. Set 'Speed Limit Switch' and 'Speed Limit Switch 2' to
'OFF' to ensure it is not invoked during tuning. Note that
this limit will only be effective if a vehicle speed sensor
is correctly wired and configured.
4. Perform a Store to permanently save changes to the ECU
by pressing F4.
Trigger Set-up
Trigger set-up requires entering information regarding the way in which engine speed and position is
measured. Consult the PCLink Tuning Software online help for further information on functions.
WARNING!
These are probably the most critical set-up values. Do not attempt to start
the engine unless you are 100% confident that these values are correct.
If trigger information is unknown, consult your nearest Link dealer for further assistance.
1. Click on ‘Triggers’ then ‘Trigger Set-up’:
a. Configure triggers as required.
2. Click on ‘Trigger1’:
a. Select correct trigger type and set-up completely.
3. Click on ‘Trigger2’:
a. Select correct trigger type and set-up completely.
4. Perform a Store to permanently save changes to the ECU
by pressing F4.
Additional Set-up
It is important that all features not required for initial tuning are either disabled or correctly set-up. It is
recommended that features be initially disabled to ensure they do not complicate tuning.
1. Click on ‘Motorsport’ then ‘Antilag’:
a. Set ‘Antilag Mode’ to OFF.
2. Click on ‘Launch Control’:
a. Set ‘Launch Control Mode’ to OFF..
3. Click on 'Gear Cut Control’:
a. Set 'Gear Cut Control Mode’ to OFF.
4. Click on Boost Control > Boost Set-up:
a. Configure Boost Control as described in the PCLink
Tuning Software online help.
5. Click on 'Multiple Boost Tables':
© 2020 Link Engine Management Ltd

G4X Plug-In ECU Installation Manual

17

a. Set 'Active Tables' to 1 Table.
6. Perform a Store to permanently save changes to the ECU
by pressing F4.

1.7.3

Essential Tuning Adjustments
It is assumed that at this stage all set-up procedures described in previous sections have been completed
and the engine is running.The following steps detail correct set-up procedures for some of the more critical
ECU parameters (note that MAP Sensor Calibration should have already been completed by now):
Injector Voltage (Dead-time) Correction
There is always a delay between the injector being energised and the injector actually opening. Likewise,
there is a small delay between the injector being de-energised and the injector closing. The opening time is
considerably longer than the closing time, however the overall result is that less fuel will flow for a given pulse
width than would be expected with an 'ideal injector'. To compensate for this the injector pulse widths are
increased to compensate for this 'dead-time'. The dead-time for a given injector is a function of the battery
voltage, differential fuel pressure and the type of injector driver (saturated or peak and hold). A typical deadtime at 3 Bar differential fuel pressure and 14 volts is just under 1ms (ms = millisecond = 1 thousandth of a
second).
In applications with a linear 1:1 fuel pressure regulator (i.e. not a rising rate regulator), the differential fuel
pressure (difference between manifold pressure and fuel pressure) will be constant. Therefore the only variable
that is changing will be the battery voltage (this changes with electrical load and sometimes engine speed).
Without correction, the changes in dead-time will cause the engine to run lean when the voltage drops. If the
Injector Voltage Correction is properly set-up then changes in the battery voltage will not affect the air/fuel
ratio.
The injector dead-time table allows the dead-time for different battery voltages to be entered. The values
represent the dead-time in milliseconds. These should increase with falling system voltage.
Injector dead-time for a particular set of injectors can be determined using a flow bench or on a running
engine.
To determine the injector dead-time using a flow bench, the injectors need to be operated at the intended
operating pressure (normally three bar) and at a constant duty cycle as well as a set voltage. Vary the supply
voltage to the injector and measure minimum pulse width at which the injectors will flow for a particular
voltage. This is the required dead-time for that injector at that tested voltage.
To determine injector dead-time on a running engine, with the engine fully warmed and operating at stable
air/fuel ratios (a very precise AFR meter is required – a narrow band O2 sensor will not suffice), electrical
drain needs to be applied to the system; the preferred method is disconnecting the alternator main fuse.
Battery load testers are also useful here too.
Watching the air fuel ratios change while the battery voltage drops, the dead-time table can be trimmed to
maintain the same stable air/fuel ratio. Injector dead-time can be viewed as a row graph. A smooth curve
needs to be maintained at all times.
NOTE: any change to the fuel pressure or injectors will require a recalibration of the injector dead-times.
Master
Master should be set so that the numbers in the middle of the fuel table end up around a value of 50. This is
to allow sufficient span of the numbers in the main fuel table.

1.8

Pinouts
Pin information is provided to assist when troubleshooting. All pinouts are looking into the ECU (wire side).

1.8.1

WRXLink (04) and WRXLink (07)
The following pin diagram is provided as a support reference. Please contact your nearest Link dealer for
specific pin information.

© 2020 Link Engine Management Ltd

18

Link ECU Online Manual

2004 - 2006 ECU Function
Pin
ECU Pin
Function
A1
DI 4
Clutch Switch
A2
nc
A3
nc
A4
nc
A5
nc
A6
Ground
A7
nc
A8
Aux 8
Tumble Valves Close
A9
Linked to A9
TGV wired in series
A10 Linked to A8
A11
Aux 7
Tumble Valves Open
A12
nc
A13
nc
A14 Injector 5 (Aux)
Purge Solenoid
A15 Injector 6 (Aux)
Cruise Light
A16 nc (Cruise Set
Light)
A17 Injector 8 (Aux)
CE Light
A18
+14V Out
AVCS Solenoid
A19
+14V Out
AVCS Solenoid
A20
nc
A21
nc
A22
nc
A23
Aux 3
Tacho
A24
nc
A25
Ground
A26
nc
A27
nc
A28
Aux 2
Bank 1 (RH) AVCS
Solenoid
A29
Aux 1
Bank 2 (LH) AVCS
Solenoid
A30
nc
A31

nc

A32
Aux 5
A33
nc
A34 Ground (Signal)
B1
Ground
B2 Injector 7 (Aux)
B3
nc
B4
Ground
B5 +14V Main Relay
B6 +14V Main Relay
B7
nc

Pin
C3
C4
C5
C6
C7
C8
C9
C10
C11
C12
C13
C14
C15
C16
C17
C18

ECU Pin
Injector 4
Injector 3
Injector 2
Injector 1
DI10
nc (Brake NO)
DI 5
DI 6
DI 7
An Temp 3
An Temp 2
An Temp 1
+5V Out
+5V Out
An Volt 10
An Volt 2

C19
C20
C21
C22
C23
C24
C25
C26
C27
C28
C29
C30

nc
nc
nc
An Volt 1
An Volt 8
nc
Knock 1
An Volt 4
An Volt 5
An Volt 9
An Volt 3
nc

C31

Ground (AFM)

C32

C34
C35

Ground (AFM
Shield)
Ground (Knock
Shield)
Ground (APS)
Ground (Signal)

D1
D2
D3
D4
D5
D6
D7
D8

Ground (Signal)
Ground (Signal)
Ground
Aux 9
Aux 10
+14V EThrottle
Ground
DI 8

C33
Wastegate Solenoid

Rear Oxy Heater

ECU Power
ECU Power

Function
Injection
Injection
Injection
Injection

Brake Switch (NC)
Cruise Cancel OR Resume
Cruise Set OR Cancel
Fuel Temperature
IAT from MAF
ECT

APS (Main)
TPS (Main)

MAP
MAF Signal
Knock
Left TGV Position
Right TGV Position
APS (Sub)
TPS (Sub)

EThrottle Motor +
EThrottle Motor From EThrottle Relay
Start Signal
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B8

Trig 2

B9

DI 2

B10
B11
B12
B13

Trig 1
nc
Ground
nc

B14
B15

nc
Ignition 4

Ignition

D15
D16

B16

Ignition 3

Ignition

D17

B17
B18
B19
B20
B21
B22
B23
B24
B25
B26
B27
B28
B29
B30
B31
B32
B33
B34
B35

C1
C2

D9

DI 9

Neutral Signal

D10

An Volt 6

Power Steer Switch

D11
D12
D13
D14

Ignition 2
Ignition
D18
Ignition 1
Ignition
D19
nc
D20
nc
D21
nc
D22
Ground (Cams)
D23
nc
D24
Ignition 5 (Aux)
AC Fan
D25
Ignition 7 (Aux)
Engine Fan
D26
Aux 6 (04) / DI 1 FP Speed (04) / Vehicle
D27
(05-06)
Speed (05-06)
DI 1 (04) / Aux 6 Vehicle Speed (04) / FP
D28
(05-06)
Speed (05-06)
nc
D29
nc
D30
nc
D31
Ground (Crank
Expansi
Shield)
on 1
nc
Expansi
on 2
Ignition 6 (Aux)
AC Relay
Expansi
on 3
nc
Expansi
on 4
Ignition 8 (Aux)
E-Throttle Relay
Expansi
on 5
Expansi
on 6
nc
Expansi
on 7
nc
Expansi
on 8

2006-2007 ECU Function
Pin
ECU Pin
A1
nc
A2

Bank 2 (LH) Cam
Position
Bank 1 (RH) Cam
Position
Trig 1 (Crank)

nc
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Pin
C3
C4

nc
nc
nc
Ignition Switch (05- Controls Main Relay (05-06)
06)
Ignition Switch (04) Controls Main Relay (04)
DI3 (04) / Main
AC Request (04) / Ground
Relay (05-06)
when on (05-06)
Main Relay (04) /
Ground when on (04) / AC
DI3 (05-06)
Request (05-06)
nc
nc
nc
nc
nc
nc
nc
An Volt 7
Rear Oxy Signal
nc
nc
nc
nc
nc
Ground (Shield)
Ground (Signal)
+5V Out
nc
nc
An Volt 12
nc
An Temp 4
An Volt 11

ECU Pin
nc (Front O2
Heater)
Injector 7 (Aux)

Function

Rear Oxy Heater
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A3
nc
A4
nc
A5
Ground
A6
An Volt 1
A7 +14V Main Relay
A8
nc
A9
nc
A10
nc
A11
DI 2

MAP (Factory)
ECU Power

Bank 1 (RH) Cam
Position

C5
C6
C7
C8
C9
C10
C11
C12
C13

nc
Ground (Shield)
nc
nc
Ignition 6 (Aux)
nc
Injector 8 (Aux)
nc (06) / Aux 6 (07)
DI 1

C14
C15
C16
C17
C18
C19
C20
C21
C22
C23

nc
Ground (Signal)
nc
nc
Ignition 7 (Aux)
Engine Fan
nc
nc
Ignition 8 (Aux)
E-Throttle Relay
Aux 3
Tacho
DI 3 (06) / Main
A/C Request (06) / Ground
Relay (07)
when on (07)
Main Relay (06) / DI Ground when on (06) / A/C
3 (07)
Request (07)
DI 4
Clutch Switch
nc

A12
A13
A14
A15
A16
A17
A18
A19
A20
A21

nc
Trig 1
Ground (Crank)
Knock 1
An Volt 4
nc
An Volt 2
+5V Out
nc
Trig 2

A22

Ground (Cams)

C24

A23
A24

nc
Ground (Crank
Shield)
Ground (Knock
Shield)
An Volt 5
nc
An Volt 3
Ground (Signal)
nc
nc
nc
An Volt 6
An Temp 1

C25
C26

A25
A26
A27
A28
A29
A30
A31
A32
A33
A34

B1 Ground (O2 Shield)
B2 +14V Main Relay
B3
nc (Cruise Set
Light)
B4
An Volt 7
B5 nc (+12V constant)
B6
Injector 6 (Aux)
B7
nc
B8 nc (Front O2 Signal
-)
B9 nc (Front O2 Signal
+)

Trig 1 (Crank)
Knock
Left TGV Position
TPS (Main)

Bank 2 (LH) Cam
Position

Right TGV Position
TPS (Sub)

Power Steer Switch
ECT

ECU Power

Rear Oxy Signal
Cruise Light

AC Relay
CE Light
FP Speed (07)
Vehicle Speed

C27

CAN 2 High

C28
C29
C30
C31
C32
C33
C34
C35

nc
Ignition 5 (Aux)
nc
DI 9
DI 8
nc
nc
CAN 2 Low

D1
D2
D3
D4

Ground
Ground
Ground
Aux 9

D5
D6
D7
D8
D9

Aux 10
nc
Ground
Injector 1
Injector 2

EThrottle Motor -

D10

Injector 3

Injection

AC Fan
Neutral Signal
Start Signal

EThrottle Motor +

Injection
Injection
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B10
B11
B12
B13
B14
B15
B16
B17
B18
B19
B20
B21
B22
B23
B24

nc (Fuel Level
Sensor)
nc
DI 10
DI 6
nc
nc
nc
An Temp 3
An Temp 2
Ignition Switch
DI 5
+5V Out (APS
Main)
+5V Out (APS
Sub)
An Volt 10
DI 7

B25
nc
B26
An Volt 8
B27
nc
B28
nc (brake NO)
B29 Ground (APS Main)
B30 Ground (Signal)
B31
An Volt 9
nc (Fuel Tank
Pressure)
B33 Aux 6 (06) / nc (07)

Cruise Main
Cruise Cancel OR
Resume

Fuel Temperature
IAT from MAF
Controls Main relay
Brake (NC)

APS (Main)
Cruise Set OR
Cancel
MAF Signal

APS (Sub)

B32

1.9

B34

Ground (AFM)

B35

Ground (AFM
Shield)

C1

+14V EThrottle

C2

nc (Front O2
Heater)

FP Speed (06)

From EThrottle
Relay

21

D11

Injector 4

Injection

D12
D13
D14

Linked to D23
Aux 8
Aux 1

TGV wired in series
Tumble Valves Close
Bank 2 (LH) AVCS Solenoid

D15
D16
D17
D18
D19
D20
D21
D22

+14V Out
Aux 2
+14V Out
Ignition 1
Ignition 2
Ignition 3
Ignition 4
Aux 7

AVCS Solenoid
Bank 1 (RH) AVCS Solenoid
AVCS Solenoid
Ignition
Ignition
Ignition
Ignition
Tumble Valves Open

D23

Linked to D12

TGV wired in series

D24
D25

nc
nc

D26
D27
D28
D29
D30
D31
Expansio
n1
Expansio
n2
Expansio
n3
Expansio
n4
Expansio
n5
Expansio
n6
Expansio
n7
Expansio
n8

Ground
Aux 5
nc
Injector 5 (aux)
nc
nc
Ground (Signal)

Wastegate Solenoid
Purge Solenoid

+5V Out
DI 11
Aux13
An Volt 11
Aux 12
An Temp 4
Aux 11

CAN Information
The following CAN (Controller Area Network) information is provided:

1.9.1

WRXLink (04) and WRXLink (07)
The G4X WRXLink (04) and WRXLink (07) Plug-in ECU has two CAN buses. These CAN buses exist to
support aftermarket CAN devices.
CAN bus 1 uses a 5 pin connector and is labeled on the ECU as 'CAN 1/RS232'.
If using this connector for CAN ensure the cable being used doesn't have Serial wires connected as this can
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act as an aerial and prevent USB communications from working.
CAN 1/RS232 Connector

Pin

Function

Colour

1

Comms GND Brown

2

CAN1 L

Green

3

CAN1 H

White

4

RS232-RX

Grey

5

RS232-TX

Yellow

CAN bus 2 uses a 5 pin connector and is labeled on the ECU as 'CAN 2/OBD'.
CAN 2/OBD Connector

Pin

Function

Colour

1

GND

Brown

2

CAN2 L

Green

3

CAN2 H

White

4

NC

Grey

5

+14V

Yellow

To learn more about CAN see PCLink help.

1.10 Known Issues
All plug-in ECUs are fully tested on a range of relevant vehicles, although there are often variations that have
not been tested. For this reason issues can arise.
WARNING: Always download the latest Installation Manual from linkecu.com and check the latest status of
known issues before installing the ECU.
Please contact your nearest Link dealer when suspecting a compatibility issue.

1.10.1 WRXLink (04) and WRXLink (07)
Some vehicles don't have fuel temp sensors, if this is the case for your vehicle then turn off the fuel sensor
input or it's incorrect temperature reading will affect your fuelling.
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